Windows Vista - http://www.vistaarticles.com
You do not have the most current version of Internet Explorer.
http://www.vistaarticles.com/articles/121/1/You-do-not-have-the-most-current-version-of-Internet-Explorer.
By 
Published on 11/23/2006
 
Describes the User Agent String Utility tool that you can use to view Web sites that do not support Internet Explorer 7.

You do not have the most current version of Internet Explorer.

To resolve this issue, you can use the User Agent String Utility tool to change how Web sites recognize Internet Explorer 7. The tool creates a browser window that emulates Internet Explorer 6. This step lets you visit and interact with Web sites that did not function as expected together with Internet Explorer 7. The tool temporarily changes settings for Internet Explorer 7 so that Internet Explorer 7 appears to be Internet Explorer 6.

Download: http://go.microsoft.com/fwlink/?LinkID=70356

How to use the User Agent String Utility tool
1. Double-click the User Agent String Utility icon.
2. Click Just change my settings. 
3. Click Change settings.